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1. はじめに

本書は D-Case エディタによるダイアグラムの編集における、実行環境である eclipse や

D-Case エディタ特有の編集操作について説明をします。

D-Case エディタに含まれる様々な機能についての詳細は、別冊の機能仕様書を参照し

てください。

また本書は D-Case エディタの実行環境が設置済みであることを前提として記述しており

ます。実行環境が未設置の場合は、別冊の設置手順書を参照して、設置を完了させてくださ

い。

1. 対象バージョン

本書はバージョン 0.8.7 の D-Case エディタを対象に記述しています。

2. 準備

D-Case エディタを利用するための準備作業について説明をします。

eclipse のプラグインアプリケーションである D-Case エディタでは、D-Case 文書を格納す

るために eclipse のワークスペース上にプロジェクトフォルダをあらかじめ作成しておく必要が

あります。以下に、そのための手順を説明します。

1. eclipseのワークスペースを作成する

eclipse を起動すると｢Workspace Launcher｣という画面が表示されます。

｢Workspace｣とは、特定のフォルダを基準としたファイルや各種設定情報の格納先で、

eclipse で行う編集作業により作成された D-Case 文書は、指定した格納先に保管されるので、

必ず作成する必要があります。

｢Workspace｣の作成先は、他のアプリケーションなどとは重ならない、新しいフォルダを

指定してください。
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2. ワークスペースにプロジェクトを作成する

Workspace に D-Case 文書を格納するための｢Project｣を作成します。

eclipse のメインメニューから Window > Open Perspective > Other で画面を開き

｢Resource｣を選択します。

File > New > Project で｢New Project｣画面を開きます。
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General > Project を選び、有効になった｢Next｣ボタンを押します。

｢Project｣画面が表示されるので、空の｢Project name｣に名称を入力します。
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｢Finish｣ボタンが有効になるので、問題が無ければ｢Finish｣ボタンを押して、プロジェクト

の作成を終了します。

なお、｢Use default location｣の設定は変更しないでください。

以上で｢Project Explorer view｣に指定した名称で、プロジェクトフォルダが作成されます。
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さらに詳しい内容は eclipse のヘルプから、Help > Help Contents > Workbench User 

Guide > Tasks > Working with projects, folders and files からご覧ください。

3. 基本操作

D-Case エディタを使ったダイアグラムの作成について、基本的な編集操作を説明します。

1. D-Case文書のファイル構成について

D-Case エディタでは、新規ダイアグラムの作成で、二つの拡張子のファイルを作成します。

エディタでの編集作業時には、常に、両方のファイルを必要とします。

.dcase_model 拡張子 D-Case ダイアグラムモデルの設定値が格納されるファイル

.dcase_diagram 拡張子 D-Case ダイアグラムモデルの図形情報が格納されるファイル

本書では、上記の二つの拡張子を持つファイルをまとめて｢D-Case 文書｣と呼称します。

D-Case エディタの実行と関連付けられている拡張子は｢.dcase_diagram｣です。

D-Case 文書を編集する場合は、｢.dcase_diagram｣ファイルをダブルクリックするか、選

択した状態で｢Open｣メニューを実行します。
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｢.dcase_model｣ファイルがプロジェクトから削除された場合、｢.dcase_diagram｣だけが存

在しても、エディタでの D-Case 文書の編集は出来ません。また｢.dcase_model｣ファイルがエ

ディタ所定の操作方法以外で Rename された場合も、エディタでの編集は出来なくなります。
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2. 新しい D-Case文書ファイルを作成して保存する

｢準備｣の説明に従って、ワークスペースとプロジェクトの作成が完了していることを前提と

して説明します。

eclipse のメインメニューから Window > Open Perspective > Other で画面を開き

｢Resource｣を選択します。

｢Project Explorer｣で、作成先のプロジェクトフォルダを選択した状態で、eclipse のメイン

メニューから File > New > Other で｢New｣画面を表示します。

D-Case Editor > D-Case Diagram を選択し、有効になった｢Next｣ボタンを押します。
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New D-Case Diagram 画面が表示されます。
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表示された画面で D-Case 文書のファイル名を入力して、｢.dcase_diagram｣ファイル名を

決定し、｢Next｣ボタンで先に進みます。

この時に変更するファイル名は、拡張子の前の部分だけを変更するようにしてください。

拡張子を変更した場合は、正常に動作しない場合があります。



D-Case Editor ユーザーズマニュアル

13

D-Case 文書の｢.dcase_model｣ファイル名が、一つ前の画面で入力したファイル名の拡

張子違いを初期値として提示するので、｢Finish｣ボタンを押して確定します。

ここまでの作業で、新規の D-Case 文書が作成され、ダイアグラムのエディタが表示され

ます。
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エディタによる編集作業の保存は、eclipseメインメニューから File > Save で行うか、ツー

ルボタンの Save ボタンで行います。

これにより現在編集中の D-Case 文書に編集結果が保存されます。
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3. 作成済みの D-Case文書ファイルを開いて別名で保存する

Resource Perspective の Project Explorer から再度編集を行う D-Case 文書を選択しま

す。この時に選択するファイルは、拡張子が｢.dcase_diagram｣のファイルを選択してくださ

い。

｢.dcase_diagram｣ファイルを選択した状態で、eclipse のメインメニューから File > Open 

を選択するか、｢.dcase_diagram｣ファイルを右クリックして表示された、ポップアップメニュー

の Open アイテムを選択します。
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この操作により、選択した D-Case 文書が編集対象としてエディタに表示されます。

編集結果を上書き保存する場合は、前節で説明した Save を使用します。
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元のD-Case文書に変更を加えず、別のD-Case文書として保存する場合は、eclipseのメ

インメニューから File > Save As…を選択します。

Save As の画面が表示されます。
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保存先のプロジェクトフォルダを決定し、ファイル名の拡張子より前の部分を変更して

｢OK｣ボタンを押して閉じます。
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指定したプロジェクトフォルダの下に、新しく指定したファイル名で D-Case 文書が保存さ

れます。

4. D-Caseエディタでノードやリンクを編集する

D-Case エディタでのダイアグラムの編集手順を説明します。

まず｢新しいD-Case文書を作成して保存する｣での説明に従い、D-Case文書の新規作成

を行います。
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新しいノードの追加は、画面右側の｢Palette｣リストから追加するノードをマウスで選択し

ます。

この図では｢Goal｣ノードが選択されています。この状態で D-Case エディタのキャンバスを

マウスクリックすると、新しい｢Goal｣ノードがキャンバスに追加されます。
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キャンバスにノードが追加されると、Palette の選択状態は外れます。

同じ種類のノードを連続して追加するには、Ctrl + マウスクリックで行うことが出来ます。

あるノードの下位に繋がるノードを追加する方法としては、ポップアップメニューから行う

方法もあります。
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いずれかのノードを選択し、右クリック > Add Child > Create New Node で表示されるノ

ードの種類から選択することで、選択元のノードからのリンクと一緒にノードが追加されます。

ノードとノードの関連を示すリンクを追加するには、画面右側の｢Palette｣リストから追加す

るリンクをマウスで選択します。

この図では｢Supported By｣リンクが選択されています。この状態で D-Case エディタのキ

ャンバス上にあるリンク元のノードからリンク先のノードへマウスをドラッグ移動して離すと、新

しい｢Supported By｣リンクが、ノードとノードの間に引かれます

キャンバスにリンクが追加されると、Palette の選択状態は外れます。

同じ種類のリンクを連続して追加するには、Ctrl + マウスドラッグで行うことが出来ます。

5. D-Caseエディタでノードやリンクのプロパティを編集する

D-Case 文書に記述されるノードやリンクには、色々な情報をプロパティ値として保持する

ことが出来ます。

ここではプロパティの編集方法について説明します。
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キャンバスに配置されているノードは、｢Name｣プロパティと｢Desc｣プロパティが常に表示

されています。

｢Name｣プロパティは、ノードの追加が行われるときに、キャンバス上に既に配置されてい

るノードと、名称がかぶらないように自動採番されます。

｢Desc｣プロパティは、そのノードについての説明書き用のプロパティです。

｢Name｣プロパティと｢Desc｣プロパティは、キャンバス上で直接編集できます。

ノードの｢Name｣プロパティか｢Desc｣プロパティの表示位置をマウスでクリックし、上図の

ように選択状態にします。

この状態で F2 キーを入力すると、テキスト編集状態になります。

入力値を確定させるには Enter キーを押します。編集を取り消すには Esc キーを押しま

す。

直接入力が編集しにくい場合には、キャンバスに配置されたノードをダブルクリックするか、

ノードを選択して Enterキーを押すことで表示される、｢Set properties｣画面で編集する方法も

あります。
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固定された入力欄が用意されているので、直接入力よりも編集が行いやすくなります。

この画面では表示されないプロパティ値の編集については、｢Properties view｣という画面

で行います。

｢Properties view｣はノードを右クリック > Show Properties View メニューを選択すること

で表示されます。

｢Set properties｣画面では編集できない項目も、｢Properties view｣では編集することが出

来ます。

また｢Properties view｣での値の編集はリンクについても同じように行うことが出来ます。
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6. D-Case文書のコピーを作成する

D-Case 文書は｢D-Case ダイアグラムのファイル構成｣で説明していますが、二種類のファ

イルで文書を構成しています。

D-Caseエディタでは、二種類のファイルをセットでコピーするための、CopyTo機能を提供

しています。

以下、機能の利用手順を説明します。

Resource Perspective の Project Explorer からファイル名の変更を行いたい D-Case 文

書の｢.dcase_diagram｣拡張子ファイルを選択します。

eclipse のメインメニューから D-Case > File > Copy To を選択します。

この時 Rename メニューアイテムが無効になっている場合は、選択している D-Case 文書

が編集用に開かれている状態なので、編集作業を終わらせて、エディタ画面を閉じてから再

度実施してください。

コピー先やファイル名を指定する画面が表示されます。
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コピー先のプロジェクトフォルダを決定し、必要に応じてファイル名の変更を行い、｢OK｣ボ

タンを押すことで、D-Case 文書のコピーが完了します。
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7. D-Case文書のファイル名を変更する

D-Case 文書は｢D-Case ダイアグラムのファイル構成｣で説明していますが、二種類のファ

イルで文書を構成しています。

eclipse の標準機能として用意されている Rename 機能は、単一のファイル名を変更する

もので、これを使って D-Case 文書のファイル名を変更すると、ファイル間の参照先が見つけ

られなくなり、D-Case 文書を開けなくなります。

このため D-Case エディタでは、｢.dcase_diagram｣ファイルに対する D-Case 文書向けの

Rename 機能を提供しています。

以下、機能の利用手順を説明します。

Resource Perspective の Project Explorer からファイル名の変更を行いたい D-Case 文

書の｢.dcase_diagram｣拡張子ファイルを選択します。

eclipse のメインメニューから D-Case > File > Rename を選択します。
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この時 Rename メニューアイテムが無効になっている場合は、選択している D-Case 文書

が編集用に開かれている状態なので、編集作業を終わらせて、エディタ画面を閉じてから再

度実施してください。

Rename の選択が実施できた場合は、Rename D-Case Files 画面が表示されます。

新しいファイル名に変更し、｢OK｣ボタンを押すと、ファイル名がまとめて変更されます。

8. D-Case文書のワークスペース外への出力とワークスペース外からの取り込

み

D-Case 文書の編集を共同で行う場合や、提出物の資料として添付するなど、D-Case 文

書を別のワークスペースへコピーする必要が起きた場合に、推奨する手順を紹介します。

Resource Perspective の Project Explorer で出力したい D-Case 文書を選択します。

この時選択するファイルは｢.dcase_diagram｣、｢.dcase_model｣の両方を選ぶ必要があり

ます。
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eclipse のメインメニューから File > Export、または、ファイルを選んだ状態でマウスの右

クリックから開く、ポップアップメニューの Export アイテムを選びます。

Export 画面が開きます。Export 画面では出力先（出力目的）の選択が求められます。
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ここではファイルを出力先にコピーするため、General > File System を選択し、｢Next｣ボ

タンを押します。
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表示された送り先のディレクトリを指定する画面で、ディレクトリパスを指定し、有効化した

｢Finish｣ボタンを押します。
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｢Finish｣ボタンが押されると、画面が閉じてファイルのコピーが行われます。

Export が完了すると指定ディレクトリにファイルが作成されています。

出力された D-Case 文書ファイルを取り込む場合は、File > Import メニューから行いま

す。
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Importメニューを選択すると、Import画面が開きます。Import画面では取り込み元の選

択が求められます。

出力したファイルを取り込む場合は、General > File System を選択して｢Next｣ボタンを押

します。
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次の画面に進むと取り込むべきファイルを指定する画面に移ります。
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取り込むべきファイルが置かれているディレクトリの選択とファイルを選択し、取り込み先

のプロジェクトフォルダを指定します。必要に応じてオプションを選択し、｢Finish｣ボタンを押す

と指定されたファイルが Workspace の中に取り込まれ、Project Explorer に表示されます。
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4. よく使う操作

D-Case エディタによる D-Case 文書の編集で、よく利用する操作やちょっとした便利な操

作について説明します。

この説明は、｢基本編｣で説明されているD-Case文書の編集操作について、理解している

ことを前提に記述します。
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1. D-Case文書の一部またはすべてを画像ファイルとして保存する

この説明は、｢基本編｣で説明されているD-Case文書の編集操作について、理解している

ことを前提に記述します。

Resource Perspective > Project Explorer から編集対象の D-Case 文書を開きます。

マウスのドラッグか、Ctrl キー+マウスクリックで、部分的に画像保存するノードとリンクを

選択状態にします。
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選択状態のノードかリンクの上にマウスを移動させ、右クリックによるポップアップメニュー

を表示し、File > Save As Image File…を選びます。

メニューを選ぶと、出力画像形式などを決定する画面が表示されます。
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出力先フォルダ、ファイル名、画像フォーマットなどを決定して、｢OK｣ボタンを押すと、選

択した部分の画像ファイルが出力されます。

ノードとリンクの選択を全て外した状態で、キャンバスの右クリックによるポップアップメニ

ューを表示し、File > Save As Image File…を選び、選択時と同様に出力画像形式などを指

定すると、キャンバス全体の画像ファイルが出力されます。
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2. D-Case文書の一部をコピーし、他のアプリケーションにペーストする

Resource Perspective > Project Explorer から編集対象の D-Case 文書を開きます。

マウスのドラッグか、Ctrl キー+マウスクリックで、部分的に画像保存するノードとリンクを

選択状態にします。
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eclipse のメインメニューから Edit > Copy かショートカットキーの Ctrl + C を実施します。

Power Point を起動し、Power Point のホームリボンから貼り付けを選ぶかショートカット

キーの Ctrl + E を実施します。
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3. ノードの検索と置換

D-Case文書に定義した何らかの文言を探したり、探した結果を置き換えたりする手段とし

て、ノードの Name プロパティと Desc プロパティを対象とした、検索・置換機能を提供していま

す。

検索・置換は D-Case エディタで開いているカレントの D-Case 文書が対象になります。

D-Case 文書を開いた状態で、eclipse のメインメニューから、D-Case > Find / Replace メ

ニューを選択します。

メニューを選ぶと、Find / Replace 画面が表示されます。

検索・置換を行いたい文言を Find欄、Replace with欄に入力し、画面下部のコマンドボタ

ンで、行いたい動作を選択します。

｢Find｣ボタンで Find に指定された文字と一致した場合、そのノードを選択状態にし、部分

一致した箇所を画面内に提示します。
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｢Replace｣ボタンで Findに指定された文字と一致した場合、Replace withに入力されてい

る置換する文字をで、一致部分を置き換えます。
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4. D-Case文書全体の配置を自動整列させる

D-Case エディタではダイアグラムの配置を自動的に整列する機能があります。

ここでは D-Case 文書全体を自動整列させる手順について説明します。

D-Case文書全体をまとめて整列させる場合は、eclipseのメインメニューから、Diagram > 

Arrange > All を選択します。

またはツールボタンの Arrange All ボタンでも同様です。

メニューのコマンドを実行すると、ダイアグラム全体の配置が調整されます。
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上図が調整前の状態で、下図が調整後の状態です。

整列の方向は、上から下の整列と、左から右の整列を選ぶことが出来ます。

eclipse のメインメニューから、D-Case > Arrange direction メニューのサブメニューに

｢Vertical｣と｢Horizontal｣という選択肢があり、｢Vertical｣が上下方向、｢Horizontal｣が左右方

向の調整となります。
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左右方向の調整は、以下のような状態になります。

選択した方向は、eclipse を終了させた後も保持されます。

自動配置する際のノードの並び順は、ノード同士を繋ぐリンクの持つ｢Sibling Order｣プロ

パティとノードの｢Name｣プロパティによって優先順位を決めます。

｢Sibling Order｣プロパティは数値指定で、同一の接続元を持つリンク同士で比較し、数値

の若い方を優先的に配置します。

｢Name｣プロパティは、文字と数値に分解して、文字の辞書順で比較し、比較結果が同じ

場合は数値でも比較を行い、優先順位を決めて配置します。比較対象は、同一の接続元ノー

ドを持つノード同士です。

｢Sibling Order｣プロパティの順番は、｢Name｣プロパティの順番よりも優先されます。
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この例では三段目の階層で並び替えが行われています。

 name 順で並べると G_2,G_3,G_4,G_5 の順となる。

 ここでは G_3,G_5 のソース側のリンクに Sibling Order が設定されている

 Sibling Orderを持つノードが優先するので、まずG_3,G_5が全体の左側に配置され

る。

 G_3 の Sibling Order が 2、G_5 の Sibling Order が 1 なので、Sibling Order 順とし

て G_5,G_3 の順で配置される。

 他のノードは name 順で G_2,G_4 の順に配置される。

 上記により、全体では G_5,G_3,G_2,G_4 の順に左から配置される。
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5. D-Case文書の選択範囲を自動整列させる

D-Case エディタではダイアグラムの配置を自動的に整列する機能があります。

ここでは D-Case 文書の選択範囲を自動整列させる手順について説明します。

D-Case 文書の選択範囲を整列させる場合は、eclipse のメインメニューから、自動調整を

行いたいノードをマウスドラッグで囲んで選ぶか、Ctrl + マウスクリックで選択状態にします。

あるノードの子孫ノードの全てを選択する場合は、ノード上で右クリック > Select subtree 

機能が便利です。
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選択状態のままeclipseのメインメニューから、Diagram > Arrange > Selection を選択し

ます。

またはツールボタンの Arrange Selection ボタンでも同様です。

メニューのコマンドを実行すると、ダイアグラムの選択部分の配置が調整されます。
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自動配置の方向を｢Horizontal｣に変更すると、以下のように変化します。
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自動配置する際のノードの並び順は、ノード同士を繋ぐリンクの持つ｢Sibling Order｣プロ

パティとノードの｢Name｣プロパティによって優先順位を決めます。

｢Sibling Order｣プロパティは数値指定で、同一の接続元を持つリンク同士で比較し、数値

の若い方を優先的に配置します。

｢Name｣プロパティは、文字と数値に分解して、文字の辞書順で比較し、比較結果が同じ

場合は数値でも比較を行い優先順位を決めて配置します。

｢Sibling Order｣プロパティの順番は、｢Name｣プロパティの順番よりも優先されます。
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ただし｢Sibling Order｣プロパティが指定されているリンクの接続元が選択状態でない場

合は、並び替えは行われません。

また｢Name｣プロパティによる比較も、比較するノード同士の接続先が、選択されていない

場合は、並び替えは行われません。

6. D-Case文書を用紙の高さや幅に合わせて印刷する

D-Case 文書を印刷する場合に、幅や高さを固定して印刷する方法を説明します。

D-Case エディタにフォーカスがある状態で、eclipse のメインメニューから File > Print…を

選択し、印刷画面を表示します。
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印刷画面にある｢拡大縮小（Scaling）｣設定項目の｢適用するサイズ（Fit to）｣でページ幅

の指定が出来ます。ここで幅または高さを1に指定します。幅を 1に設定した場合の高さの値、

高さを 1 に設定した場合の幅の値については、自動調整はされず、指定した枚数の用紙を使

用しますので、実際に紙に印刷する前に、ファイル出力用のプリンターなどで試験印刷を行う

ことをお勧めします。

上手く印刷調整できない場合は

編集によってノードを座標のマイナス方向に配置している場合、原点がずれて印刷時に

正常な印刷ができないことがあります。この場合の確認方法と対応方法を説明します。

確認方法
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1. Diagram>View>Rulers でルーラーを ON にする

2. 編集画面の左上のルーラーが 0,0 原点とならず、マイナス方向まで表示されている

か確認する

上記の状態になっていた場合、以下の回避策をとることで正常に印刷できます。

対応方法

1. 新しく D-Case 文書を作成する

2. 問題となっている D-Case 文書ですべての要素を選択する

3. 新しく作成した D-Case 文書に選択したすべての要素を張り付ける

その他

印刷に関連して、印刷設定情報からページブレークの補助表示の方法を説明します。

D-Case エディタにフォーカスがある状態で、eclipse のメインメニューから Diagram > 

View > Page Breaks を選択します。

選択を行うと、D-Case エディタのキャンバスに、ページ分割の補助線が表示されます。
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ページを跨がないように配置する場合の参考にご利用ください。
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