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Introduction 
 

The D-Case Weaver is a web version of D-Case Editor and has the basic functions of D-Case 

Editor. 

A .dcase file which D-Case Weaver generates is upward compatible with the file which 

D-Case Editor generates. 

But the extended function in D-Case Weaver is not implemented in D-Case Editor. 

 

Extended Function: Editing D-Script configuration parameters. 

 (Please refer to Section 8 “D-Script Parameters”) 

 

For D-Case Editor, please refer to this web site. 

http://www.dependable-os.net/tech/D-CaseEditor/index-e.html 

 

 

For installation of D-Case Weaver, please refer to “A1. D-Case Weaver Installation Guide”. 

For a quick start of the D-Case Weaver, please refer to “A2. D-Case Weaver User’s Manual”. 

 

http://www.dependable-os.net/tech/D-CaseEditor/index-e.html
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1 User Interface 
 

 
 

Figure 1-1 User Interface 

 

1. Menu bar 

2. Tool bar 

3. Drawing area for D-Case diagram 

4. Statistics information 

 

1 

2 

3 
4 
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2 Creating and Saving a D-Case 
 

2.1 Creating a New D-Case 
 

To create a new D-Case, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “New”. 

Empty D-Case diagram 

will be drawn in the 

drawing area. 

You can do the same by 

clicking the “New” button 

on the tool bar. 

 

 

2.2 Opening an Existing D-Case 
 

To open an existing D-Case, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Open”. 

The Open D-Case dialog 

will be displayed. 

You can do the same by 

clicking the “Open” button 

on the tool bar. 

2 Select a file from the File 

List on the dialog. 

  

3.1 Click the “OK” button. The D-Case diagram will 

be drawn in the drawing 

area and the dialog will 

close. 

 

3.2 Click the “Cancel” button The dialog will close.  

 

Open D-Case dialog 

 
Figure 2-1 Open D-Case dialog 

  

 

 

 

 

 

File List 
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2.3 Saving a D-Case 
 

To save a D-Case, follow the procedure below. 

 

Saving a D-Case 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save”. 

If the file has been saved, 

the D-Case will be saved. 

Otherwise, go to the 

following “Saving as a New 

D-Case” Procedure 2. 

You can do the same by 

clicking the “Save” button 

on the tool bar. 

 

 

Saving as a New D-Case 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save As”. 

The Save D-Case dialog 

will be displayed. 

 

2 From the File List on the 

dialog, select a directory in 

which to save the D-Case. 

The directory name will be 

displayed in the Directory 

field. 

 

3 Enter file name in the File 

Name field. 

  

4.1 Click the “OK” button. The D-Case will be saved 

and the dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Save D-Case dialog 

 
Figure 2-2 Save D-Case dialog 

 

 

File List 
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2.4 Saving as an Image File 
 

To save a D-Case diagram in the PNG image format, follow the procedures below. 

 

Saving entire D-Case diagram 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save As Image 

File”. 

The Save As Image File 

dialog will be displayed. 

 

2 Optionally, enter a scale 

factor in the Scale field. 

 If you want to save in half 

scale, enter “0.5” in the 

field. 

3.1 Click the “OK” button.  The image file will be 

downloaded. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Saving a sub-tree rooted at a selected node 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Save As Image 

File”. 

The Save As Image File 

dialog will be displayed. 

 

3 Go to “Saving entire D-Case diagram Procedure 2” above. 

 

Limitation 

 

An image which is no more than 8192x8192 pixels can be saved. 

If you want to save an entire diagram which is greater than 8192x8192 pixels, specify 

appropriate offsets in pixels and save a part of the diagram, and repeat the step for the next 

part until all parts are saved. 

 

Save As Image File dialog 

 
Figure 2-3 Save As Image File dialog 
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3 Editing Functions 
 

3.1 Adding a Child Node 
 

To add a child node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Add Child”. Node types will be listed on 

the context menu. 

 

3 Select a node type to be 

added. 

A new node will be added.  

 

 

3.2 Editing a Node 
 

To edit a node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Edit Node” The Node Editor dialog will 

be displayed. 

 

3 Edit the node.   

4.1 Click the “OK” button. The changes will be 

applied to the node and the 

dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  
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Node Editor dialog 

 
Figure 3-1 Node Editor dialog 

 

 

Changing the Order of Sibling Nodes 

 

In the Change Node Order tool, you can change the order of sibling nodes by dragging and 

dropping the node. 

 

         
Figure 3-2 Changing the Order of Sibling Nodes 

 

 

 

 

 

 

 

 

 

 

 

 

 

Drag & Drop 

Change Node Order tool 
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3.3 Deleting a Node 
 

To delete a node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Delete Node”. The node will be deleted.  

 

 

3.4 Adding a Link 
 

To add a link, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Add Link”.  “Parent” and “Child” will 

be displayed on the context 

menu. 

 

3 Select “Parent” or “Child” The link, a red arrow for 

editing, will be displayed. 

When “Parent” is selected, 

the link is displayed on 

parent side on the node. 

When “Child” is selected, 

the link is displayed on 

child side. 

4 Drag the starting or ending 

point of the link and drop it 

on a node to link. 

  

5 Click places other than the 

starting and ending point 

of the link. 

The changes will be 

applied and the link will be 

hidden. 

 

 

      
Figure 3-3 Editing a Link 

 

 

 

 

 

 

 

Drag & Drop 
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3.5 Deleting a Link 
 

To delete a link, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a link. The context menu will be 

displayed. 

 

2 Select “Delete Link”. The link will be deleted.  

 

 

3.6 Undoing and Redoing 
 

To undo, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Undo”. 

The previous operation will 

be removed. 

You can do the same by 

clicking the Undo button 

on the tool bar. 

 

 

To redo, follow the procedure below. 

 

No. Procedure Result Note 

1 From menu bar, select 

“Edit” > “Redo”. 

The previous undo 

operation will be removed. 

You can do the same by 

clicking the Redo button 

on the tool bar. 

 

When undoing and/or redoing cannot be performed, the Undo and/or Redo items on the 

menu bar and the Undo and/or Redo button on the tool bar are disabled. 

 

 
Figure 3-4 Undo / Redo button 
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4 Attachment 
 

4.1 Attaching a URL 
 

To attach a URL, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Attachment”. The Attachment dialog will 

be displayed. 

 

3 Enter a URL in the URL 

field. 

  

4.1 Click the “OK” button. The changes will be 

applied and a clip icon will 

be attached to the node and 

the dialog will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

You can remove the attachment by blanking the URL field. 

 

Attachment dialog 

 
Figure 4-1 Attachment dialog 

 

4.2 Opening an Attachment 
 

To open an attachment, follow the procedure below. 

 

No. Procedure Result Note 

1 Click the clip icon in a 

node. 

The attachment will open.  

 

 
Figure 4-2 Clip icon 
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5 Searching for a Node 
 

To search for a node, follow the procedures below. 

 

No. Procedure Result Note 

1 Enter the name of the node 

to be searched in the 

Search field on the tool bar. 

The node candidates will 

be listed every time a 

character is entered. 

 

2 From the list of node 

candidates, select a node. 

The diagram will move as 

the selected node is 

displayed in center of the 

screen. 

 

 

Search Node Tool 

 

 
Figure 5-1 Search Node Tool 

 

 

 

6 Viewing Statistics Information 
 

You can show or hide statistics information by using the Show/Hide Statistics Information 

Tool. 

 

Show/Hide Statistics Information Tool 

 
Figure 6-1 Show/Hide Statistics Information Tool 
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7 Repository Operations 
 

The root directory of a repository as follows: 

/var/lib/dcase-weaver/documents 

 

You can do the following operations for files and directories under the root directory. 

 Opening a file 

 Creating a directory 

 Deleting a file or a directory 

 Uploading a file 

 Downloading a file 

 

7.1 Common Operations 
 

To open the Repository Browser, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Browse”. 

The Repository Browser 

will be displayed. 

 

 

The following operations in Section 7.2 to 7.6 start from this state. 

 

Repository Browser 

 
Figure 7-1 Repository Browser 

 

7.2 Opening a File 
 

To open a file, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

file. 

  

2 Click the “Open” button. The selected file will open 

in a new window. 

A file may be downloaded 

depending on the file type. 

 

File List 
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7.3 Deleting a File or Directory 
 

To delete a file or directory, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

file or directory. 

  

2 Click the “Delete” button. The selected file or 

directory will be deleted. 

 

 

7.4 Uploading a File 
 

To upload a file, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

destination directory to 

upload a file. 

  

2 Click the “Upload” button. The Upload dialog will be 

displayed. 

 

3 In the dialog, select a file 

by clicking the “Choose 

File” button. 

 The label of the button 

may differ in browsers 

other than Chrome. 

4 Enter a file name in the 

File Name field. 

  

5.1 Click the “OK” button. The file will be uploaded 

and the dialog will close. 

 

5.2 Click the “Cancel” button. The dialog will close.  

 

Upload dialog 

 
 

Figure 7-2 Upload dialog 

 

 

7.5 Downloading a File 
 

To download a file, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a   
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file. 

2 Click the “Download” 

button.  

The selected file will be 

downloaded. 

 

 

 

7.6 Creating a Directory 
 

To create a directory, follow the procedures below. 

 

No. Procedure Result Note 

1 From the File List, select a 

directory. 

 A new directory will be 

created in the selected 

directory. 

2 Click the “Make Directory” 

button.  

The Make Directory dialog 

will be displayed. 

 

3 Enter a directory name.   

4.1 Click the “OK” button. A new directory will be 

created and the dialog will 

close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Make Directory dialog 

 
Figure 7-3 Make Directory dialog 
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8 D-Script Parameters 
 

You can set a D-Script and its parameters for performing the D-Script in a node. 

 

 

8.1 D-Script Template File 
 

A D-Script template file has information about available D-Scripts. 

The information of each D-Script includes a template to generate a configuration file and 

information on each parameter for a D-Script. 

 

Using this template file, a D-Script and its parameters for performing the D-Script are set in 

a node. 

 

The sample D-Script template file is located in the path below. 

/usr/share/dcase-weaver/d-script-template-sample/d-script-template.xml 

 

Schema of D-Script Template File 

<?xml version="1.0" encoding="UTF-8"?> 
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
           xmlns="http://www.dependable-os.net/d-script" 
           elementFormDefault="qualified" 
           targetNamespace="http://www.dependable-os.net/d-script"> 
  <xs:element name="d-script"> 
    <xs:complexType> 
      <xs:sequence> 
        <xs:element name="monitors" minOccurs="0"> 
          <xs:complexType> 
            <xs:sequence> 
              <xs:element name="monitor" type="module_type" 
                          minOccurs="0" maxOccurs="unbounded"/> 
            </xs:sequence> 
          </xs:complexType> 
        </xs:element> 
        <xs:element name="actions" minOccurs="0" > 
          <xs:complexType> 
            <xs:sequence> 
              <xs:element name="action" type="module_type" 
                          minOccurs="0" maxOccurs="unbounded"/> 
            </xs:sequence> 
          </xs:complexType> 
        </xs:element> 
      </xs:sequence> 
    </xs:complexType> 
  </xs:element> 
 
  <xs:complexType name="module_type"> 
    <xs:sequence> 
      <xs:element name="name" type="xs:string"/> 
      <xs:element name="description" type="xs:string"/> 
      <xs:element name="version" type="xs:string"/> 
      <xs:element name="license" type="xs:string"/> 
      <xs:element name="author" type="xs:string"/> 
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      <xs:element name="config_template" type="xs:string"/> 
      <xs:element name="config_path" type="config_path_type"/> 
      <xs:element name="explanations" type="explanations_type"/> 
      <xs:element name="parameters" type="parameters_type"/> 
    </xs:sequence> 
  </xs:complexType> 
 
  <xs:complexType name="config_path_type"> 
    <xs:simpleContent> 
      <xs:extension base="xs:string"> 
        <xs:attribute name="extension" type="xs:string" use="required"/> 
      </xs:extension> 
    </xs:simpleContent> 
  </xs:complexType> 
 
  <xs:complexType name="explanations_type"> 
    <xs:sequence> 
      <xs:element name="explanation" maxOccurs="unbounded"> 
        <xs:complexType> 
          <xs:simpleContent> 
            <xs:extension base="xs:string"> 
              <xs:attribute name="lang" type="xs:string" use="required"/> 
            </xs:extension> 
          </xs:simpleContent> 
        </xs:complexType> 
      </xs:element> 
    </xs:sequence> 
  </xs:complexType> 
 
  <xs:complexType name="parameters_type"> 
    <xs:sequence> 
      <xs:element name="parameter" minOccurs="0" maxOccurs="unbounded"> 
        <xs:complexType> 
          <xs:sequence> 
            <xs:element name="description"/> 
            <xs:element name="default"/> 
          </xs:sequence> 
          <xs:attribute name="name" type="xs:string" use="required"/> 
          <xs:attribute name="type" type="xs:string" use="required"/> 
          <xs:attribute name="min" type="xs:string" use="optional"/> 
          <xs:attribute name="max" type="xs:string" use="optional"/> 
        </xs:complexType> 
      </xs:element> 
    </xs:sequence> 
  </xs:complexType> 
</xs:schema> 

 

 

 

 

 

 

 

 

 



©2013 JST D-Case Weaver Specification DEOS Project 

Page. 20  2013/07/15 

8.2 CGI Program for Deploying Configuration Files 
 

A CGI program (hereafter described as “Deploy application”) generates a D-Script 

configuration file based on a D-Script template file and a D-Case file and deploys the 

configuration file. 

 

D-Case Weaver sends the following Request to “Deploy application”. 

 

 HTTP METHOD 

POST 

 

 REQUEST 

 PARAMETER 

No parameters 

 

 BODY 

<?xml version="1.0" encoding="utf-8"?> 
<xs:schema targetNamespace="http://www.dependable-os.net/dre" 

elementFormDefault="qualified" 
           xmlns:xs="http://www.w3.org/2001/XMLSchema" 

xmlns:dcase="http://www.dependable-os.net/2010/06/dcase" 
xmlns:d-script="http://www.dependable-os.net/d-script"> 

 
<xs:element name="deploy"> 
<xs:complexType> 
<xs:sequence> 
<xs:element ref="dcase:dcase"/> 
<xs:element ref="d-script:d-script"/> 

</xs:sequence> 
</xs:complexType> 

</xs:element> 
</xs:schema> 

 

Example XML 

<?xml version="1.0" encoding="utf-8"?> 
<deploy xmlns="http://www.dependable-os.net/dre"  
xmlns:dcase="http://www.dependable-os.net/2010/06/dcase" 
xmlns:d-script="http://www.dependable-os.net/d-script"> 
<dcase:dcase> 
“Contents of D-Case” 

</dcase:dcase> 
<d-script:d-script> 
“Contents of D-Script Template”  

</d-script:d-script> 
<deploy> 
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Sample “Deploy application” 

 

D-Case Weaver includes a sample of “Deploy application”. 

You can use it by setting up the contents of the URL below. For the setting procedure, refer 

to Section 8.3 ”Setting up Configuration”. 

 

cgi-bin/deploy.php 

 

 

8.3 Setting up Configurations 
 

To set up, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Set up the configurations 

of the D-Script. 

  

3.1 Click the “OK” button. The configurations will be 

applied and the dialog will 

close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Configurations 

 

Name Description 

Template Path The location of a D-Script template file 

 

For example: 

 /project1/d-script.xml 

Deploy URL The URL of a deploy application 

 

For example: 

 cgi-bin/deploy.php 

 

 

8.4 Editing a D-Script 
 

To select a D-Script and edit its parameters, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Edit D-Script”. The D-Script dialog will be 

displayed. 

 

3 Select a D-Script from the 

drop-down menu. 

Information of selected 

D-Script will be displayed. 
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4 Edit the D-Script 

parameters. 

  

5.1 Click the “OK” button. The parameters will be 

applied and the dialog will 

close. 

 

5.2 Click the “Cancel” button. The dialog will close.  

 

D-Script parameters are added to a node with the following XML schema. 

<?xml version="1.0" encoding="utf-8"?> 
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
xmlns="http://www.dependable-os.net/dre" elementFormDefault="qualified" 
targetNamespace="http://www.dependable-os.net/dre"> 
  <xs:element name="d-script"> 
    <xs:complexType> 
      <xs:sequence> 
        <xs:element name="full-name" type="xs:string"  maxOccurs="1" minOccurs="1"/> 
        <xs:element name="values" maxOccurs="1" minOccurs="1"> 
          <xs:complexType> 
            <xs:sequence> 
              <xs:element name="value" type="ValueType" maxOccurs="unbounded"/> 
            </xs:sequence> 
          </xs:complexType> 
        </xs:element> 
      </xs:sequence> 
    </xs:complexType> 
  </xs:element> 
  <xs:complexType name="ValueType"> 
    <xs:simpleContent> 
      <xs:extension base="xs:string"> 
        <xs:attribute name="name" type="xs:string" use="required"/> 
      </xs:extension> 
    </xs:simpleContent> 
  </xs:complexType> 
</xs:schema> 
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D-Script dialog 

 
Figure 8-1 D-Script dialog 

 

 

 

 

8.5 Deploying D-Script Configuration Files 
 

To create and deploy D-Script configuration files, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“D-Script” > “Deploy”.  

D-Script configuration files 

will be generated and be 

deployed. 

The D-Script configuration 

files are deployed in the 

directory specified with 

config_path in a D-Script 

template file. 

 

Note: 

The directory where D-Script configuration files are deployed must be writable by www-data 

a user. 

Drop-Down menu 



©2013 JST D-Case Weaver Specification DEOS Project 

Page. 24  2013/07/15 

9 Monitoring 
 

D-Case Weaver gets each node status from a status server and changes the node color 

according to the status. 

 

The status is obtained in text format from a status server by HTTP protocol. 

 

 HTTP METHOD 

GET 

 

 REQUEST 

 PARAMETERS 

No parameters 

 BODY 

No data 

 

 RESPONSE 

 

The response is text formatted as follows. 

 

Id=”Goal node ID” status=”Status” message=”Message” 

 

The line delimited by a new line character is repeated every Goal. 

 

The character encoding must be UTF-8. 

 

 

Parameters 

 

Name Description 

Goal node ID ID of the node of the monitoring target 

Status Select one of the following strings 

 normal 

 running 

 error 

Message Message 

 

 

Status and Color 

 

Status Color 

normal White 

running Yellow 

error Red 
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9.1 Setting up Configurations 
 

To set up, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Set up the configurations of 

Node Status Monitor. 

  

3.1 Click the “OK” button. The configurations will be 

applied and the dialog will 

close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Configurations 

 

Name Description 

URL The URL of a status server 

 

For example: 

 cgi-bin/node-status.wsgi/project1.dcase 

Interval[ms] The monitoring interval, in milliseconds 

 

For example: 

 10000 

 

 

9.2 Starting a Monitoring 
 

To start a monitoring, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Monitor” > “Start”. 

The monitoring will start.  

 

 

9.3 Stopping a Monitoring 
 

To stop a monitoring, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Monitor” > “Stop”. 

The monitoring will stop.  
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9.4 Sample Program 
node-status.wsgi 

 

This CGI script returns node statuses. 

 

Location 

/usr/share/dcase-weaver/www/cgi-bin/node-status.wsgi 

 

URL 

cgi-bin/node-status.wsgi 

 

Usage 

Add the path of a D-Case file to the URL and request. 

For example, to get the status of /test/test.dcase, set up the following. 

 

cgi-bin/node-status.wsgi/test/test.dcase 

 

 

node-status-client.py 

 

This CLI sends the status of a node to a status server. 

 

Location 

/usr/share/dcase-weaver/bin/node-status-client.py 

 

Usage 

python node-status-client.py [–H HOST] PATH NODE_ID [STATUS] [MESSAGE] 

 

A status of the node whose ID is NODE_ID in the D-Case which is located in PATH is set to 

STATUS. 

Optionally, set MESSAGE. 

 

Option 

-H HOST, --host=HOST 

  To remote execute, specify the HOST name 
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10 Cooperation Function with DS-Bench 
 

D-Case Weaver cooperates with DS-Bench to provide the functions below. 

 Getting test scenarios from DS-Bench. 

 Setting up parameters of a test scenario 

 Starting a test scenario 

 Adding a node according to the evaluation result of a test scenario 

 

For the installation and the usage of DS-Bench/Test-Env, refer to the following documents 

and web site. 

 DS-Bench/Test-Env Specification (DEOS-FY2013-BS-01E) 

 DS-Bench/Test-Env Setup Manual(DEOS-FY2013-BI-01E) 

 DS-Bench/Test-Env Execution Manual(DEOS-FY2013-BT-01E) 

 http://www.dependable-os.net/tech/DSBenchDCloud/index-e.html 

 

10.1 Setting up Configurations 
 

To set up the cooperation function with DS-Bench, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Set up the configuration of 

the DS-Bench. 

  

3.1 Click the “OK” button.  The configurations will be 

applied and the dialog will 

close. 

 

3.2 Click the “Cancel” button. The dialog will close.  

 

 

Configurations 

 

Name Description 

Name The name of DS-Bench server 

URL The URL of DS-Bench server 

 

 

10.2 Selecting a test scenario 
 

To select a test scenario prepared by DS-Bench, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a Strategy 

node. 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > 

“Select Scenario”. 

The Scenario List dialog 

will be displayed. 

 

3 Select a test scenario.   

4.1 Click the “OK” button. The Goal node will be  

http://www.dependable-os.net/tech/DSBenchDCloud/index-e.html
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added and the dialog will 

close. 

4.2 Click the “Cancel” button. The dialog will close.  

 

By the procedures on the S_1 Strategy node, the G_1 Goal node is added to the Strategy 

node as below. 

 

 
Figure 10-1 Selecting a test scenario 

 

Scenario List dialog 

 
Figure 10-2 Scenario List dialog 

 

 

10.3 Setting up Parameters 
 

To set up parameters of a scenario, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click the Goal node 

added in Section 10.2. 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > “Set 

Parameters”. 

The Scenario Parameters 

dialog will be displayed. 

 

3 Set parameters   

4.1 Click the “OK” button. The parameters will be 

applied and the dialog will 

close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

The parameters are test scenario specific. 
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Scenario Parameters dialog 

 
Figure 10-3 Scenario Parameters dialog 

 

 

10.4 Starting a Test Scenario 
 

To start a test scenario, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click the Goal node 

added in Section 10.2 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > 

“Execute” 

The test scenario will 

start. 

 

 

During execution of a test scenario, the execution status is displayed in the node. 

 
Figure 10-4 Execution Status 
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After completion of a test scenario, a node is added according to the evaluation result. 

If the result is satisfactory, a blue Evidence node is added. 

 
Figure 10-5 Satisfactory 

 

 

If the result is unsatisfactory, a red “Undeveloped” node is added. 

 

 
Figure 10-6 Unsatisfactory 

 

You can see the execution result details screen of DS-Bench if you click the clip icon in the 

node. 
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10.5 Stopping a Test Scenario 
 

To stop a test scenario, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click the Goal node 

added in Section 10.2. 

The context menu will be 

displayed. 

 

2 Select “DS-Bench” > 

“Cancel” 

The test scenario will stop.  
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11 Module 
 

D-Case Weaver provides a modularization function which saves a part of D-Case as a new 

file. The modularized part is represented as a module node in the current D-Case. 

 

11.1 Modularizing 
 

To create a module, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a node. The context menu will be 

displayed. 

 

2 Select “Module” > 

“Modularize”.  

The Modularize dialog will 

be displayed. 

 

3 Enter the name of the 

module. 

  

4.1 Click the “OK” button. The modularized sub-tree 

will be saved as a new file 

and be represented as a 

module node in the 

diagram. And the dialog 

will close. 

 

4.2 Click the “Cancel” button The dialog will close.  

 

Modularize dialog 

 
Figure 11-1 Modularize dialog 

 

If the G_2 node in Figure 11-2 is modularized, the diagram is as in Figure 11-3. 

 

Before Modularization 

 
Figure 11-2 Before Modularization 
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After Modularization 

 
Figure 11-3 After Modularization 

 

The destination to save the module 

The destination to save the module is the same as the directory where the current D-Case 

file is located. 

 

 

11.2 Selecting a Module 
 

To select a module, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a Module or 

Goal node. 

The context menu will be 

displayed. 

 

2 Select “Module” > “Select 

Module”. 

The Select Module dialog 

will be displayed. 

 

3 Select a module.   

4.1 Click the “OK” button. The module will be set in 

the node and the dialog 

will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Select Module dialog 

 
Figure 11-4 Select Module dialog 
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11.3 Un-modularizing 
 

To un-modularize, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a Module node The context menu will be 

displayed. 

 

2 Select “Module” > 

“Un-modularize”. 

The module will be 

un-modularized. 

 

 

If the Figure 11-3 is un-modularized, the diagram is as below. 

 

 
Figure 11-5 Un-modularizing a Module 

 

 

11.4 Showing/Hiding inside of a Goal/Module Node 
 

To show/hide inside of a Goal/Module node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click a modularized 

node. 

The context menu will be 

displayed. 

 

2 Select “Module” > 

“Show/Hide Module” > 

“Show”. 

The D-Case which was 

modularized will be 

displayed in the node. 

To hide the expanded 

view, select “Hide”. 

You can do the same by 

clicking the +/- icon in the 

node. 
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When the inside of Module node in Figure 11-3 is shown, the diagram changes as below. 

 

 
Figure 11-6 Exposed View of a Node 
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12 Cooperation Function with Alfresco (Community 

Edition) 
 

12.1 Setting up Configurations 
 

To set up the configuration of a cooperation function with Alfresco (Community Edition), 

follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“Edit” > “Preferences”. 

The Preference dialog will 

be displayed. 

 

2 Check the “Use Alfresco” 

check box of Alfresco. 

  

3 Set up the configurations of 

Alfresco. 

  

4.1 Click the “OK” button. The configuration will be 

applied and the dialog will 

close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Configurations 

 

Name Description 

Use Alfresco If checked, the cooperation function is enabled. 

If not checked, the cooperation function is disabled. 

If you change this configuration, you must restart your browser. 

CMIS URL The CMIS AtomPub binding URL 

 

For example: 

 http://[host]:[port]/alfresco/service/cmis 

User The user ID of Alfresco 

 

12.2 Login 
 

When accessing the Alfresco server for the first time after starting D-Case Weaver, a login 

dialog is displayed. 

 

Login dialog 

 
Figure 12-1 Login dialog 
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12.3 Creating a New D-Case 
 

This procedure is same as that in Section 2.1 “Creating a New D-Case”. 

 

12.4 Opening an Existing D-Case 
 

To open an existing D-Case, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Open”. 

The Open D-Case dialog 

will be displayed. 

You can do the same by 

clicking the “Open” button 

on the tool bar. 

2 From the drop-down menu, 

select a repository. 

The File List will be 

updated. 

 

3 From the File List, select a 

file. 

  

4.1 Click the “OK” button. The D-Case diagram will 

be displayed in the 

drawing area and the 

diagram will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

Open D-Case dialog 

 
Figure 12-2 Open D-Case dialog 
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12.5 Saving a D-Case 
 

To save a D-Case, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save”. 

If the file has not been 

saved, go to the following 

“Save D-Case dialog”.  

Otherwise, go to the 

“Comment dialog” below 

You can do the same by 

clicking the “Save” button 

on the tool bar. 

 

 

Save D-Case dialog 

 

No. Procedure Result Note 

1 From the drop-down menu, 

select a repository. 

The File List will be 

updated. 

 

2 From the File List, select a 

directory. 

  

3 Enter a file name in the 

File Name field. 

  

4.1 Click the “OK” button. If a file with the same 

name already exists, go to 

the following “Comment 

dialog”. 

Otherwise, the D-Case will 

be saved and the dialog 

will close. 

 

4.2 Click the “Cancel” button. The dialog will close.  

 

 

 
Figure 12-3 Save D-Case dialog 

 

 

 

File List 

Drop-Down menu 
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Comment dialog 

 

No. Procedure Result Note 

1 Enter a comment in the 

Comment field. 

  

2.1 Click the “OK” button.  The D-Case will be saved 

and the dialog will close. 

 

2.2 Click the “Cancel” button. The dialog will close.  

 

 
Figure 12-4 Comment dialog 

 

Save as a New D-Case 

 

To save as a new D-Case, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Save As”. 

The Save D-Case dialog 

will be displayed. 

 

2 Go to the “Save D-Case dialog” 

 

 

12.6 Registering a Document 
 

To register a document in the Evidence or Context node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click on an Evidence 

or Context node. 

The context menu will be 

displayed. 

 

2 Select “Document” > 

“Browse”. 

The Node Documents 

dialog will be displayed. 

 

3 From the Repository 

Document List, select a 

document. 

  

4 Click the “Add” button. The document will be 

registered in the node and 

will be listed in the 

Document List. 
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Node Documents dialog 

 
Figure 12-5 Node Documents dialog 

 

 

12.7 Unregistering a Document 
 

To unregister a document from the Evidence or Context node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click on an Evidence 

or Context node. 

The context menu will be 

displayed. 

 

2 Select “Document” > 

“Browse”. 

The Node Documents 

dialog will be displayed 

 

3 From the Document List, 

select a document 

  

4 Click the “Delete” button.  The document will be 

unregistered and will be 

removed from the 

Document List. 

 

 

 

12.8 Opening a Document 
 

To open a document registered in the Evidence or Context node, follow the procedures below. 

 

No. Procedure Result Note 

1 Right-click on an Evidence 

or Context node. 

The context menu will be 

displayed. 

You can do the same via 

the Document dialog. 

2 Select “Document” > 

“Browse” 

The Node Documents 

dialog will be displayed. 

 

Repository Document List 

Document List 

Drop-Down menu 
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3 From the Document List, 

select a document. 

  

4  Click the “Open” button. The document will open.  

 

 

12.9 Uploading a Document to the Repository 
 

To upload a document to the repository, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Document” > 

“Browse” 

The Document dialog will 

be displayed.  

You can do the same via 

the Node Document dialog. 

2 From the file list, select the 

destination directory to 

upload the document. 

  

3 Click the “Upload” button. 

 

The Upload dialog will be 

displayed. 

 

4 Select a file to upload.   

5 Enter the file name in the 

File Name Field 

  

6.1 Click the “OK” button. The document will be 

uploaded and the Upload 

dialog will close. 

 

6.2 Click the “Cancel” button. The Upload dialog will 

close. 

 

 

Document dialog 

 
Figure 12-6 Document dialog 

 

 

 

 

 

 

 

 

File List 

Drop-Down menu 
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Upload dialog 

 
Figure 12-7 Upload dialog 

 

 

12.10 Updating a Document 
 

To update a document in a repository, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Document” > 

“Browse”. 

The Document dialog will 

be displayed. 

You can do the same via 

the Node Document dialog. 

2 From the File List, select a 

file. 

  

3 Click the “Commit” button. The Commit dialog will be 

displayed. 

 

4 Select a file to be 

committed. 

  

5 Enter comments in 

Comment field. 

  

6.1 Click the “OK” button. The file will be committed 

and the Commit dialog will 

close. 

 

6.2 Click the “Cancel” button. The Commit dialog will 

close. 
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Commit dialog 

 
Figure 12-8 Commit dialog 

 

 

12.11 Checking for Modifications 
 

Documents which have been modified are detected and nodes which have modified 

documents are colored yellow. 

 

To check for modifications, follow the procedure below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Document” > 

“Check for modifications”. 

The Check for 

modifications dialog will be 

displayed and nodes which 

have a modified document   

will be changed to yellow. 

Status of modified 

documents is displayed as 

“changed” in the Check for 

modifications dialog. 

 

 
Figure 12-9 Checking for Modifications 
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Check for modifications dialog 

 
Figure 12-10 Check for modifications dialog 

 

 

12.12 Viewing History 
 

To view history, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Document” > 

“Browse”. 

The Document dialog will 

be displayed. 

You can do the same via 

the Node Document dialog. 

2 From the File List, select a 

document. 

  

3 Click the “History” button.  The History dialog will be 

displayed. 

If you click the “Open” 

button, the document will 

open. 

 

History dialog 

 
Figure 12-11 History dialog 
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12.13 List of Linkage Node 
 

The node which is linked to a document is searched from the current D-Case file and D-Case 

files in the directory where the current D-Case file is located. 

 

To list nodes which are linked to a document, follow the procedures below. 

 

No. Procedure Result Note 

1 From the menu bar, select 

“File” > “Document” > 

“Browse”. 

The Document dialog will 

be displayed. 

You can do the same via 

the Node Document dialog. 

2 From the File List, select a 

document. 

  

3 Click the “Linkage Node” 

button. 

 

The Linkage Node List 

dialog will be displayed. 

 

 

 

Linkage Node List dialog 

 
Figure 12-12 Linkage Node List dialog 
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Appendix 
 

A1. D-Case Weaver Installation Guide 
 

System Requirements 
 

We have confirmed that D-Case Weaver works in the following system environments. 

 

 OS 

 Ubuntu 12.04 

 Browser 

 FireFox (Version 20.0) 

 Chrome (Version 26.0) 

(Internet Explorer is not supported.) 

 

Download 

 

You can download the Debian package of D-Case Weaver from the following URL. 

http://www.dependable-os.net/tech/DCaseWeaver/index-e.html 

 

 

Installation 

 

To install D-Case Weaver, execute the following commands. 

$ sudo apt-get install apache2 python python-setuptools libapache2-mod-wsgi 

libapache2-mod-php5 python-beaker 

$ sudo dpkg -i dcase-weaver_0.1.0_all.deb 

(The filename of the package may change depending on the version.) 

 

 

http://www.dependable-os.net/tech/DCaseWeaver/index-e.html
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A2. D-Case Weaver User’s Manual 
 

Starting D-Case Weaver 

 

Enter the following URL in the address bar of your browser. 

http://<HOST>/dcase-weaver/index.html 

(<HOST> is the host name or IP address of the host where D-Case Weaver has been 

installed.) 

 

Creating a Node 

1. To open the context menu, right-click on a part of the drawing area other than nodes and 

links. 

2. Select “New Node” > “Goal”. 

 
3. A new Goal node will be created. 

 
Adding a Child Node 

1. To open the context menu, right-click on a node. 

2. Select “Add Child” > “Strategy”. 
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3. A Strategy node will be added. 

 
 

Editing a Node 

1. To open the context menu, right-click on a node. 

2. Select “Edit Node”. The Node Editor dialog will be displayed. 

 
3. Edit the contents of the node, then, click the “OK” button. 
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4. The changes will be applied to the node. 

 
 

Deleting a Node 

1. To open the context menu, right-click on a node. 

2. Select “Delete Node”. 

 
3. The node will be deleted. 

 
Attaching a URL to a Node 

1. To open the context menu, right-click on a node. 

2. Select “Attachment”. The Attachment dialog will be displayed. 
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3. Enter a URL in the URL field in the dialog. 

 
 

4. The URL will be set in the node and a clip icon will appear in the node.  

 
5. You can open the URL in a new window by clicking the clip icon. 

 
 



DEOS Project D-Case Weaver Specification ©2013 JST 

2013/07/15  Page. 51 

Editing a Link 

1. To open the context menu, right-click on a link. 

2. Select “Edit Link” 

 

 
3. A red arrow will appear. 

 
 

4. Drag the starting or ending point of the arrow and drop it on the node to be linked. 

 
5. To apply the changes, click a place other than the starting and ending point of the arrow. 
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Arrange a Diagram 

1. To open the context menu, right-click on a part of the drawing area other than nodes and 

links. 

2. Select “Arrange”. 

 

 
3. The diagram will be arranged. 

 
Saving a D-Case 

1. Click the “Save” button on the tool bar. The Save D-Case dialog will be displayed. 

2. Select a directory in which to save the D-Case and enter a file name. 

3. Click the “OK” button. The D-Case will be saved. 
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Opening a saved D-Case 

1. To open the Open D-Case dialog, click the “Open” button on the tool bar. 

2. Select a D-Case file. 

3. Click the “OK” button. The D-Case diagram will be displayed. 
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